Parts Availability Delays due to COVID-19
Incident Report for Motorly
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 06:42 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 08, 2021 - 07:28 EST
Update
We are continuing to work on a fix for this issue.
Posted Jul 03, 2020 - 14:30 EDT
Identified
Certain parts depending on the unit being services are experiencing extended delays on part availability. We are monitoring the situation and will report when the situation has been corrected.
Posted May 23, 2020 - 17:42 EDT
This incident affected: Part Suppliers.